Altering mouse scroll speed in Linux - article comments

Support BikeGremlin

Help BikeGremlin stay online with a Patreon donation:

Status
Not open for further replies.

BikeGremlin

Administrator
Staff member
To prevent article pages from being miles long, but preserve all the useful questions and answers provided over time, I've decided to copy/paste the website comments to the forum - and "move" further discussions here.

These are the comments from the article:
Altering mouse scroll speed in Linux

This topic is closed for further replies.

If you can't find the answer to your question in this thread, please open a separate thread with your question/problem, in an appropriate forum section (this is the General (IT-related) section).

Relja
  1. Cat
    16/11/2019 at 01:14
    No NO NO
    This is microsoft bullshit. I don’t need to install ANYTHING to adjust settings. We need to have this setting exposed. 3rd party apps just pollute the computing environment.
    • 3fd0d771d754ced79ca6b702635900b5.jpg

      Relja
      16/11/2019 at 08:26
      Can you propose another way of doing this, or provide a link where an alternative solution is explained in a noob-friendly way?
  2. 7bc771e0214c4053f688c094f2b96cc8.jpg

    Cees Timmerman
    26/11/2019 at 13:45
    I’d gladly pay Bill Gates 100 USD or whatever Windows 10 costs nowadays to not have to waste my time on this cryptic GNU BS. Maybe even get a Mac and practical accent input as well.
    • 7bc771e0214c4053f688c094f2b96cc8.jpg

      Cees Timmerman
      26/11/2019 at 15:18
      webupd8.org/2015/12/how-to-change-mouse-scroll-wheel-speed.html worked:
      sudo apt-get install imwheel
      gedit ~/.imwheelrc
      Paste this, save, and close gedit:
      “.*”
      None, Up, Button4, 3
      None, Down, Button5, 3
      Control_L, Up, Control_L|Button4
      Control_L, Down, Control_L|Button5
      Shift_L, Up, Shift_L|Button4
      Shift_L, Down, Shift_L|Button5
      imwheel –kill –buttons “4 5”
      Add previous command to autostarts (maybe ~/.bashrc).
    • 7bc771e0214c4053f688c094f2b96cc8.jpg

      Cees Timmerman
      08/01/2020 at 15:07
      Compose key works in X11 (not Wayland!). Tested in KDE of kubuntu-desktop on Ubuntu 19.10. Enable via advanced keyboard settings.
    • 376f979f3693355b2986a7005a0f39ec.jpg

      Andy Turfer
      23/01/2020 at 16:09
      It’s not “GNU BS” – it’s a choice. You choose and use what’s right for you – no-one is trying to take that away from you. Personally, I choose freedom, as I strongly believe the little quirks and a few “rough edges” here and there are well worth it.
      On a side-note, I have built a very successful career on Linux, so I donate back much more than $100 – every single year 🙂 Linux works for me, but it sounds like it rubs you up the wrong way.
    • 2d5bc64c602b2de30fddfa996a4245e1.jpg

      Cees Timmerman
      17/11/2021 at 00:00
      “chromium” instead of “.*” to only affect Chromium and avoid turning 5 to 17 line scroll in GNOME Terminal 3.36.2.
      Linux Mint Cinnamon is my favorite OS at the moment, as i couldn’t even log into Windows 10 on a brand new HP Envy using my work email, and MacOS requires an Apple ID to update preinstalled software. Then again, Firefox caused the entire system to lag, but i’m not sure whether that also occurs on Windows as i switched to Chrome there as well and added my OOM Killer to avoid thrashing. Maybe Minix is the only truly reliable OS.
  3. 136ed9f083416a41f3976c5484ab5978.jpg

    Glenn
    02/01/2020 at 03:06
    This worked perfectly. Thank you for the tutorial.
  4. 54d1945ebf52ee25553ea3856a2299ea.jpg

    Paulo
    03/01/2020 at 23:55
    Worked great! Thanks a lot! 🙂
  5. 3fd0d771d754ced79ca6b702635900b5.jpg

    Relja
    04/01/2020 at 10:40
    Thank you all for the feedback. Glad it has helped. 🙂
    • Thomas Ernst
      01/02/2020 at 22:05
      thx a lot, your script solved my problem too! 🙂
    • 2390cdbf82a262e2fb3d2949edd69f71.jpg

      Kamrul
      13/02/2020 at 08:53
      Worked wonderfully. Thank you 🙂
    • 358407e6c8e13baee92f8ffa859700ec.jpg

      Mike
      22/04/2020 at 10:55
      Thanks a lot. It worked perfectly for me. The slow scroll speed was driving me nuts…
    • f26aaab1c30ee112b4270130ff7ce2f9.jpg

      na
      26/04/2020 at 06:17
      Thanks, you rock. I’ll never understand why Ubuntu doesn’t have on option to change the scroll speed.
    • 1648b9dadd46671f1b6ace4eb3a078ca.jpg

      Alex
      27/04/2020 at 04:33
      Thank you so much!
      Why Ubuntu still doesn’t offer an option to adjust this by default is beyond my comprehension.
      But I’m having a minor issue: everything was fine until I realized that now my “back” and “forward” buttons aren’t working and I think the script somehow has blocked this function. They were working normally for web pages and Dolphin navigation before. Do you have any clue on what might have happened?
 
Last edited:
    • LFOM
      01/05/2020 at 18:45
      Nice, it works even in Gnome running over Wayland, one just need to use a toggle before the command to make sure it can display the dialog window in Xwayland:
      XDG_BACKEND=x11 ./mouse.sh
      And just to clarify things a bit, the mouse.sh script just need to run when you want to change the scroll speed, the settings are actually saved to ~/.imwheelrc file, and read every time the daemon starts. You just need to use “sudo imwheel -k” if you want to change the command, like when you add ‘-b “4 5″‘, after the daemon is already running to prevent a ‘ghost’ process, like it was explained in the askubuntu site.
      PS: You may want to check your site service, I got a bunch of 503 errors (service not available) yesterday, and I almost gave up posting the comment…
      Regards
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        01/05/2020 at 19:41
        Thank you very much for the info. 🙂
        As for the website problems, I had found and “eliminated” the culprit – as explained here in more details:
        https://io.bikegremlin.com/14941/seo-framework-vs-yoast/#7.2
        (the part after “Update 1st May 2020”)
        Please let me know if you run into any more problems.
      • 0ebab319e0f2d6e0ef2c17c58b248cbc.jpg

        LFOM
        03/05/2020 at 23:46
        Just a quick fix, as I cannot edit my reply: the correct environment variable to be used (XDG_BACKEND does nothing) is GDK_BACKEND=x11, this will force a program to run on Xwayland, when it is compatible with XOrg only.
    • 6ad0e6bc336800e3d730f6b2549d5df4.jpg

      Designer Resource
      03/05/2020 at 21:07
      Boom, it’s help me out of the terrible scroll speed in ubuntu, thank you.
      Also, I have back/forth button in my mouse too, I tried imwheel -k -b “4 5” but seem it not work, not sure what wrong, is it different between each mouse?
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        03/05/2020 at 22:37
        Not sure – my mouse, for example, had no problems even without using those options.
      • 6ad0e6bc336800e3d730f6b2549d5df4.jpg

        Designer Resource
        07/05/2020 at 10:06
        I tried set it in startup application and seem it’s a bit different from.
        As I don’t have startup delay: https://photos.app.goo.gl/qAij8zCn1TB54jKT7, is it normally?
        Sorry, but I just tried switch to linux 2 weeks and I still can’t control it good as much as I want.
      • 436974eb4332060695bd9c8bdb5755c5.jpg

        marimba
        19/06/2020 at 04:27
        I had some issues too. I fix them by modifying the file /etc/X11/imwheel/startup.conf
        I changed IMWHEEL_START=0 to IMWHEEL_START=1
        So there’s no need to add the startup application.
        On the same file, uncommented the IMWHEEL_PARAMS line and changed it to:
        IMWHEEL_PARAMS=’-b “4 5″‘
        that kept my other buttons working
    • 5f573b01cafc9ff0aebdb17718b42d7f.jpg

      Alan
      08/05/2020 at 20:42
      Thank you!!!!!
    • 394c1f729caac5e263968719a880fae9.jpg

      Semyon
      12/06/2020 at 23:01
      Thanks, but can I add these rules only for mouse, not for the touchpad?
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        13/06/2020 at 07:25
        Not that I know – maybe others can help. If touchpad input is defined differently (button numbers, as mentioned in the Troubleshooting section), then I suppose it could be configured. But I don’t think that is the case.
    • cab21feb9f76f3e8e6de9793f01d4837.jpg

      maniass
      23/06/2020 at 03:40
      Thanks a lot! This is making my life a lot easier 🙂

  1. Stéphane
    03/07/2020 at 18:19
    the imwheel’s window is opening at each login, is there an option to start and apply settings but not open windows ? – Thx anyway for the trick
    • 3fd0d771d754ced79ca6b702635900b5.jpg

      Relja
      03/07/2020 at 21:52
      I’m not having that problem.
      For solving, I’d start with double checking the contents of the mouse.sh (or however it was named in this case).
      If there’s a line, or something else missing.
    • 44201841a7037aea09a54599b505404f.jpg

      Stéphane
      04/07/2020 at 09:44
      My error.. i’ve put mouse.sh in the startup rather than iwheel… corrected, run perfectly ! 🙂
      Thx
  2. 6babf08822b8ffb3b08b7844a4222bbd.jpg

    Legit Tomasi
    23/07/2020 at 12:19
    Excellent.
    My system froze after the first attempt.
    After a restart, it works perfectly.
    Thank you!
  3. 16105313b87317f44c7c19b8dfb12daa.jpg

    olavi
    06/08/2020 at 15:54
    I have two hard drives with different linux distributions. When I boot linux from disk B, the mouse scroll speed is always the same. Instead, when I start the operating system from the disk A when the last time I used a hard disk B as a mouse scroll speed is very high. When I disconnect the mouse and put it back, the mouse scroll speed returns to normal. So the problem is probably somehow on the hard drives. Operating systems don’t matter.
    Can anyone tell me why this is?
  4. 4047ff740f9c17487e7c919f9ff0f76a.jpg

    Devin
    08/08/2020 at 21:54
    If you use a logitech mouse, try installing solaar and enable wheel resolution. It will produce windows like silky smooth scrolling.
  5. bab66e5c794eb889f9a11b5688ed9eb2.jpg

    bob
    04/09/2020 at 09:59
    Thank you, worked perfectly
 
    • Raj
      06/10/2020 at 03:03
      This is driving me crazy. I have imwheel -b “4 5” replaced for the last line of text, but this only preserves the functionality of the back and forward buttons of my mouse if, on startup application preferences, I click browse next to the command and click on mouse.sh instead of just typing in imwheel as the command. But by doing this, the imwheel window for the scroll speed pops up every time I restart. There’s just no solution!
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        06/10/2020 at 05:48
        In this article I wrote down what has worked for me, on about 4 different computers (laptops and desktops). Step by step.
        In my experience, it is important to not miss/skip any steps written down here. That’s the first thing I do when troubleshooting – double check.
        (Well, actually, the first thing I do is look for manuals and tutorials – after all else fails. 🙂 )
    • 002fd0e1718212ea1a8354ac28aa3f48.jpg

      Iain Collins
      14/10/2020 at 14:55
      This is perfect, it works exactly as expected, while preserving the functionality of extra buttons such as back/forward on Intellimouse Pro. Thank you!
    • efc2758c8abf5dd09ef049c0943e2b3a.jpg

      Stephane
      21/10/2020 at 10:03
      Thank you so much for this tuto, it works like a charm! And it’s probably the clearest step by step guide I’ve seen so far. Just what I needed.
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        21/10/2020 at 13:01
        Wrote it so that I can easily use it at any later date – without the need for any further brain strain on my part. 🙂
    • 5794b2b87260bf8c530a8772765dae1e.jpg

      Mira
      03/11/2020 at 22:09
      It doesn’t work at all. No matter what speed do I select, the response is always the same slow scrolling.
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        04/11/2020 at 10:39
        When facing a problem like this, here’s what I’d do to troubleshoot:
        1) Check the instructions, step by step. Did I miss, or skip something?
        2)Check if imwheel is running (even after a restart). Linux mint has a GUI for that, called “System Monitor”. Imwheel should be listed there.
        If running some other distro, or if you prefer the terminal, run the command:
        “ps axu”
        It will provide a list of all the processes. Is imwheel listed there?
    • 6a5dc57cf297c166890d2d3474bab6b8.jpg

      Little Leo
      29/12/2020 at 08:06
      Thank you SO much!
      It is the little things that pile un-wanted pressure on the mind. Thank you so much for taking this load away!
      This is a super well written, fantastically supported with screen shots, etc. I am using XFCE4 and some of my windows are looking, well, more XFCE like, but it is perfect.
      I look forward to being able to use more you your help at any point – I will indeed keep watch for your name when I need a tutorial for some Linux aspect.
      You trully made my day 😉
      • 3fd0d771d754ced79ca6b702635900b5.jpg

        Relja
        04/01/2021 at 12:41
        Glad it helped. 🙂
        Though I’m far from a Linux expert. It took me quite some time to figure this out – and was pretty annoying not being able to tweak the mouse scroll speed.
        Wrote this article for easy reminder/reference, primarily to myself, for when I need it again (any new Linux install etc.). And I’d still have to rely on it to get that done. 🙂

  1. Albert Zeyer
    18/01/2021 at 19:53
    Is Imwheel still up-to-date?
    You will find a couple of alternative options here: https://askubuntu.com/questions/285689/increase-mouse-wheel-scroll-speed/
    I implemented an own small script which also supports mouse scroll wheel acceleration. It’s a simple Python script which you can just run in the background.
    https://github.com/albertz/mouse-scroll-wheel-acceleration-userspace
    • 3fd0d771d754ced79ca6b702635900b5.jpg

      Relja
      19/01/2021 at 21:01
      Don’t know about imwheel being up-to-date, but it still works fine on several computers I had set it up on.
      Thanks for the links. 🙂
    • b01fd8dde2acd2311c2c36a412645499.jpg

      mijorus
      15/05/2021 at 11:52
      Still works for me in 2021, I hope this feature will be integrated in Wayland soon!
  2. ddec71b14655843266963f6d300b0d31.jpg

    Stozen
    03/02/2021 at 15:29
    Thank you very much
  3. f1101edf54b7a8c333ed0ea10b63f284.jpg

    Jamie
    14/04/2021 at 06:21
    Nice “how to guide” Relja!! This has been bugging me for so long. Works a treat on Ubuntu 20.04 LTS with my Logitech M525 mouse. Fastest scolling ever. I love it!
  4. 749caaf2ef527a1d07f65a66e2aa25c1.jpg

    nholl
    24/05/2021 at 15:39
    It worked perfect for me. Thanks for the tutorial.
  5. 9a0b359a945952a99bf43e1b42dd762d.jpg

    Bogdan
    14/01/2022 at 21:37
    Tested this on Zorin OS. Works like a charm.
    Many thanks to Relja for sharing this with us!
    • 3fd0d771d754ced79ca6b702635900b5.jpg

      Relja
      18/01/2022 at 08:39
      Hi Bogdan,
      You’re welcome, glad it could help. 🙂
      Thanks for the feedback regarding Zorin OS distro.
  6. jredfield
    29/01/2022 at 16:35
    thanks, this helped. but this is also one of the reasons why nobody sane uses Linux 😀 I need it as a dev environment and that’s it
  7. 0560a37645a71a0d8a5240fa39371ced.jpg

    CLOVIS NOGUEIRA DOMINGUES JUNIOR
    20/03/2022 at 21:25
    Thanks very much for your help!
  8. 696a236c3c156fca19289e302f25b553.jpg

    deleatur
    24/04/2022 at 11:01
    Amazing! It worked flawlessly. Thank you so much!
  9. 86bff3d83cf23c2b3716f4e795d41fb9.jpg

    justin
    15/06/2022 at 06:13
    Okay, so this accelerated my scroll speed like crazy, and I’ve tried reducing it to 1 again, but it doesn’t fix it.
 
This topic is closed for further replies.

If you can't find the answer to your question in this thread, please open a separate thread with your question/problem, in an appropriate forum section (this is the General (IT-related) section).

Relja
 
Status
Not open for further replies.

Adverts

Back
Top Bottom